I use C++ and in certain projects, I am already halfway there.
I don’t (brain processes the photons bouncing off the object and colliding with the cones and rods in the retina) a problem with this.
(See what I did there?)
(I think I met my dad joke quota for the month.)
🤮
Self-explanatory code doesn’t need comments!
Great. Now that my code is self-documenting it is somehow also not legible?
Make up your damn minds, peeps!
Is this… clean code ? 💁♂️ 🦋
Starting my day off with this absolutely cursed image, thank you OP.
I see. So that’s why people put comments before variable declarations.
I mean, this is overdoing it a bit and the “thisVarMakesItSoThat” part is redundant, but other than that those are very descriptive property- and method names, which is not a bad thing.
It wouldn’t need to say HighContrastForAccessibilityPurposes though, it would ideally just be HighContrast, and the “for accessibility purposes” would be a comment, right?
Well the “Purposes” can definitly be dropped. I guess “HighContrast” would be enough if there is only a single high contrast setting, but if there are multiple then I think “HighContrastForAccessibility” would be totally fine.
Exactly this, it distinguishes it from
HighContrastForNerfedPlayer
Variable names shouldn’t need comments, period. You don’t want to look it up every time this variable is used in code, just to understand what it holds. Of course there are always exceptions, but generally names should be descriptive enough to not need additional explanation.
And context can also come from names of other things, e.g. name of a class / namespace that holds this variable. For example
AccessibilitySettings.HighContrast
, where AccessibilitySettings holds all options related to accessibility.Yeah but “HighContrast” is enough; if you need to know the Why and not the What you can find a comment at the definition. There’s not need to carry the whole Wiki article everytime you need to use the variable.
I think the argument about “for accessibility” is missing the point a little bit and a common mistake most developers make.
You should endeavour to make your interface accessible by default. You shouldn’t be thinking in terms of “okay here’s the design and here’s the design that’s accessible”, you should be considering accessibility in all of your designs.
Now that’s usually a bit harder with games because you have styles and themes that you don’t want to detract from, but if your interface causes accessibility issues, it’s generally going to be bad for people that don’t have accessibility needs as well.
Accessibility benefits everyone.
The curse of camel case!
SnakeCase
youCannotImagineTheLookOfDisgustOnMyFace
PascalCase
Looks ugly until you need to implement something and realize you’ve been blessed with a description of business logic.
Until they find out that the way to descriptive variables or functions needs to be extended with new business logic requiring renaming of functions again and again.
I think maintaining code with this level of verbose naming, will be a pain over time. If they don’t let the naming slip, and then they could as well use cryptic 3 letter names.
Strong names are great, but (sometimes) mentioning the type of variable in the name is redundant.
Reminds me of this https://lemmy.world/post/12487512
yeah, PascalCase is the worst
public class GameManager : MonoBehaviour { public bool EnableHighContrast; public bool PlayerWon; public float PlayerUnitsMoved; public int PlayerDeathCount; public float PlayerHealth; public void PlayerTakeDamage(float damage) { PlayerHealth -= damage; if (PlayerHealth < 0) { PlayerDieAndRespawn(); } } public void PlayerDieAndRespawn() { return; } }
I couldn’t contain myself.
Yay, escaped the fight with 0 health!
This is floating point. We also need to know what happens when you escape with -0.
Well if you have a “down but not dead” condition then yes, you could escape a fight with 0 health (assuming you have teammates/pawns that can save you).
Too readable, please make each name a paragraph describing its function and how it relates to the other variables/functions around it
Should it be
PlayerHealth <= 0
?
Otherwise the player could have 0 health and not die? I’m sleep deprived so forgive me if I’m wrong
You are correct.
Counting this meme as my first FOSS contribution
Holy shit I was there with you sir! With the zeros and stuff
I know this is /c/Progammerhumor, but I wanted to pull on this thread a little bit for my own edification. I’m a Python guy and have been a while, but I’ve dabbled in other languages. The screenshot says “MonoBehaviour” which makes me assume this is mono or a .Net-like language (you know what happens when you assume).
If your player health is a float, would mono or .Net have an issue comparing the float with integer zero “0”? I mean, it seems like floating point precision may make it impossible for it to ever “equal” integer zero, but it also seems like the code isn’t accounting for that precision error.
Am I overthinking this?
Floating point errors are a product of how floating points work as a mathematical concept. So they’re independent of the programming language and can happen everywhere.
In this case though, I doubt it’s a critical issue. So the player “died” when they actually had 0.000000000027 hp left or whatever. Who cares? Do you need to be that precise?
Hanging on with 1.70E-31 health.
This won’t work if you can ever take more than 1 damage. If you were at 1 and received 2 damage you would become invincible. You’d want to do less than or equal to.
Open up ticket first, please. Thanks Codemonkey.
You are correct about it allowing you to have zero health and not die, but whether or not that’s the correct behavior will depend on the game. Off the top of my head I know that Street Fighter, some versions at least, let you cling to life at zero.
I called the takeDamage function and my player disappeared: send 'elp everything foobar
Don’t worry! this issue will be fixed in the next patch. In the meantime just try not getting hit.
The doctor prescribed “getting good”
Aah… Like reading a novel. But with a lot of weird punctuation… Or maybe just like a novel then.
This is something that can easily get refactored, because the purpose of alia the variables is right there in the name. This is way better that spending three days to try to figure out what the purpose of var1 is.
Nah, refactoring this would be a bitch. Your function name contains everything that happens in the function. Which means if you add something to it, you also have to change the name of the function. So CallThisWhenThePlayerTakesDamageAndIfThePlayerHealthIsLessThanZeroThenAlsoTheyDie would have to go to something like CallThisWhenThePlayerTakesDamageAndIfThePlayerHealthIsLessThanZeroThenAlsoTheyDieAndIncrementTheTotalDamageTakenCounter if you added something else.
IDE renames all references, no issue
oh such hope
in a week
IntegerThatTracksOneThingForOnePurpose
will be an object tracking 30% of the game state and mutated in 15 places without ever being renamed